1. Introduction

The FHV publishes its timetables to students and faculty as well as to those interested in future studies. Timetables can be accessed online or downloaded in iCalendar from https://timetable.fhv.at. All information are available in both languages German and English.

2. User Interface

The features of the user interface are described in the following section. It allows you to access both standard and customized timetables. Note that customized timetables are available to students and staff only.

2.1. Main Menu

The main menu is at the upper right corner of the page. It allows switching between German and English language. Note that changing the language not only affects the current page but all subsequently accessed information such as user documentation, and timetables, too. The Help link leads to the user documentation. The Login link will provide a form for authentication.

2.2. Navigation

2.2.1. Standard Timetables

Here you can access standard timetables. The options to chose from are the Semester of interest, the kind of Resource such as lecturer, degree program, course or room, and finally which Entry of the selected resource. Authenticated user’s timetables show the lecturer’s name. The Advanced Customization and the Access Procedure are described in the next section. Before authentication protected resources are marked with a *. Upon selection of such resources an alert will pop up.
2.2.2. My Timetables

This feature allows you to create customized timetables. You can compose a customized timetable out of several standard timetables and remove none relevant events individually.

1. Create and/or select Profile:
To add a new timetable use the +-Button. Next enter a name for your new timetable. If you wish to copy an existing timetable you can change the setting in the following drop-down box. Finally hit the Create-Button. To delete one of your timetables use the Button that says 

2. Customize and save your timetable:
Next start customizing your timetable by adding several standard timetables. After selecting a standard timetable all its events are being loaded. You can remove none relevant events by opening the event list and unselecting events. The Advanced Customization allows to select certain weeks, event categories and event information. Before leaving the page changes need to be saved.
3. Access your timetable
When the customization has been completed and saved the timetable can be accessed in two different formats:

ICS:
To access the timetable in ICS-Format you can either copy the link from the text field and than use it for import or subscription in your calendar application or download the file for further use.

HTML:
To access the timetable online simply click the link Open in browser.

2.2.3. Feedback
If you wish to leave some feedback, please use the following form.
2.2.4. What's new

Visit the section What's new to stay informed about changes.

3. Data Format

3.1. ICS

iCalendar is a file format for exchanging calendaring and scheduling information that has the file extension .ics. Most contemporary calendaring applications allow importing of iCalendar files and some also allow subscribing to an URL that returns an iCalendar file. The advantage of subscribing is the automatic update performed by the application, as opposed to importing a timetable once. Applications may allow importing through an URL, but without performing any updates. Some vendors call this feature a subscription, which is misleading. Instructions for importing or subscribing to calendars for various calendaring applications can be found in the appendix.

3.2. HTML

HTML is the traditional way of viewing timetable in your web browser. To return from a timetable to the access tool use the FHV Timetables link. To view a list of all standard timetables use the legacy list by clicking the Celcat Finder link.
3.2.1. Navigation of a timetable

The timetable covers all weeks of a semester and can be viewed tabular or itemized as list. To focus on individual weeks the FILTER selection can be used. For quick access to a particular week without filtering the GO TO selection can be used. Note that the GO TO selection is disabled when the FILTER is active. The VIEW selection allows toggling the view. Underneath the title of the timetable the time of data generation is displayed.

![Figure 1 Tabular View](image1)

![Figure 2 Itemized View](image2)

3.2.2. Printing

There is a separate print version of the timetables where the header and menus have been removed. Note that printing background colors is a browser setting and is usually suppressed by default for saving ink. For instructions how to adjust browser settings in favor of printing background colors read the appendix.

4. Language

Both the application and its documentation and the timetables are available in German and English. An exception to that rule are room names that are only available in German and notes, that are usually available in the language the event is being held in. Names of courses are generally available in both languages. However, courses that are being held in English sometimes do not have a German name at all. The language selection is taking place through the main menu.
5. Data Refresh Period

After a timetable has been refreshed with data from the database, it is being cached for one hour. Subsequent requests of the same resource within that period receive the same data. This is a trade off between delivering most recent data and delivering data fast. The online timetable reveals the last update time underneath the timetable title.

6. Protected Resources and Authentication

Names of faculty are protected resources and therefore available to students and staff only. To authenticate use the Login link in the main menu. Students and staff can login with their FH Vorarlberg user credentials. Others can return to the main page by clicking the link Not Registered.

To stay logged in check the respective box. However, we recommend using this option from private computers or private user accounts only.

Note that links created from logged in users are subject to the data policy below.

7. Data Policy

Authorized user may download timetables containing names of faculty. That data shall not be copied, transferred or otherwise be made available to third parties without the written consent of FHV.
Anhang A. Event Categories

<table>
<thead>
<tr>
<th>Event Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vorlesungsfreie Zeit</td>
<td>On such days no courses are being held. However, they are no public holidays.</td>
</tr>
<tr>
<td>Tutorium</td>
<td>Tutorial</td>
</tr>
<tr>
<td>TLV</td>
<td>Interdisciplinary course</td>
</tr>
<tr>
<td>Sprachkurs</td>
<td>Language course, voluntary</td>
</tr>
<tr>
<td>SE [Sperrzeit]</td>
<td>Reserved time for elective course seminars</td>
</tr>
<tr>
<td>SE</td>
<td>Seminar</td>
</tr>
<tr>
<td>RP</td>
<td>Revision course</td>
</tr>
<tr>
<td>PR</td>
<td>Exam</td>
</tr>
<tr>
<td>MB [Sperrzeit]</td>
<td>Reserved time for Module Library of Master Programs</td>
</tr>
<tr>
<td>MB</td>
<td>Course of Module Library of Master Programs</td>
</tr>
<tr>
<td>EX</td>
<td>Excursion</td>
</tr>
<tr>
<td>CO</td>
<td>Coaching</td>
</tr>
<tr>
<td>Schlosshofen</td>
<td>Continuing Education Program of Schlosshofen</td>
</tr>
<tr>
<td>Interne Veranstaltung</td>
<td>Internal event</td>
</tr>
<tr>
<td>Gesperrt</td>
<td>Reservation of resources for reasons not covered elsewhere, such as maintenance.</td>
</tr>
<tr>
<td>VER</td>
<td>Event</td>
</tr>
</tbody>
</table>
Anhang B. Celcat Finder

In addition to the access tool described above one can browse standard timetables with the legacy list. That list can be accessed through the Celcat Finder link on the HTML timetable.
Anhang C. Microsoft Outlook 2003

For importing iCalendar into Outlook 2003 it is suggested to install the following plug-in:
http://remotecalendars.sourceforge.net/

C.1. Students

Students are recommended to use Outlook 2007, which is available on PCs on campus. To work with Outlook 2003 on your own PCs the installation of the above plug-in is suggested. For help contact helpdesk@fhv.at.

C.2. Guest Lecturer

To work with Outlook 2003 on your own PCs the installation of the above plug-in is suggested. For help contact helpdesk@fhv.at.

Note that the RemoteCalendars plug-in may decrease the performance of Outlook 2003 and frequent pop-ups may be an annoyance.
Microsoft Outlook 2007 supports importing iCalendar files.

**D.1. Import**

1. File
2. Import and Export ...
3. Import an iCalendar (.ics) or vCalendar file (.vcs)
4. Chose the downloaded file
5. “Open as new” creates a new Calendar in Outlook. Events will not show in the main Outlook calendar. “Import” will add events to the main Outlook calendar.

**D.2. Delete**

1. View
2. Current View
3. By Category
4. Highlight events named “Fhcourse-...” and delete

**D.3. Subscribe**

1. Tools
2. Account Settings
3. Internet Calendars
4. New
5. Enter Calendar URL
6. Add
7. Check Update Limit
8. OK
E.1. Import

1. File
2. Open
3. Import
4. Import an iCalendar (.ics) or vCalendar file (.vcs)
5. Chose the downloaded file
6. "Open as new" creates a new Calendar in Outlook. Events will not show in the main Outlook calendar. "Import" will add events to the main Outlook calendar.

E.2. Delete

1. Right-click on the calendar
2. Delete Calendar
3. Yes

E.3. Subscribe

1. Select tab Home or Folder
2. Open Calendar
3. From Internet ...
4. Enter the location of the internet calendar you want to add to Outlook
5. OK
6. Advanced ...
7. All fields are optional, but the last one. Keep the Update Limit checked.
8. Yes
Anhang F. Microsoft Outlook 2016

Start a **Browser** and type the following address: [https://timetable.fhv.at](https://timetable.fhv.at)

Find the calendar you want.

Mark address using the hotkey `<STRG>+<A>`

Copy Address to Windows Clipboard

Start **Outlook2016**

Goto „Start” > Open Calendar > From Internet...
Paste the address from the windows clipboard and

Press Button [OK]

Button [Advanced…]

Folder Name: e.g. „Degree Programm GL_BWL“

Button [OK]
Button [Yes]

Since now you can find the Calendar „Degree Program GL_BWL“ within section „Other Calendars“. 
Anhang G. Microsoft Entourage 2008

To import iCalendar files into Entourage pull the file over the application. The date will be added to your “Standard” account. If the FHV account is set as the standard account, data will be added to the exchange account.
iCal supports importing and subscribing to iCalendar files.

**H.1. Import**

File > Import … > Import an iCal file

**H.2. Subscribe**

Calendar > Subscribe … > enter Calendar URL > Adjust Auto-Refresh field for automatic updates

---

**Figure 3 - Configuration of the subscription**

iCal updates calendars at the configured frequency. Observe the status symbol next to the subscribed calendar for successful updates. The exclamation mark in the figure below indicates a problem during the update. In a good state you see no symbol.

---

**Figure 4 - Updating of timetable BWBB6 failed**
Anhang I. Google Kalender

Google Calendar supports both importing and subscribing to iCalendar data.

I.1. Import

At the bottom of the Other calendars list on the left, click the Add button and select Import calendar.

I.2. Subscribe

At the bottom of the Other calendars list on the left, click the Add button and select Add by URL.

For further information read [http://www.google.com/support/calendar/](http://www.google.com/support/calendar/)

I.3. Known Issues

I.3.1. Subscribe

- It seems that most URLs to FHV timetables are too long for this service. The current work around is cropping the URL with services such as [http://tinyurl.com/](http://tinyurl.com/).
- An official statement regarding the update cycle of subscribed calendars was not found. According to online discussions the Google Calendar updates calendars once in 24 hours. However, online discussions also reveal that the service does not work reliably and days can pass between updates. The only way to verify an update of your calendar is by deleting and re-importing it.

Information Services will keep an eye on the Google Calendar service and publish updates in this manual.
Anhang J. Printing background colors from the browser

J.1. Internet Explorer

Depending on the version of Internet Explorer one of the following methods should work:

File > Page Setup > Print Background Colors and Images

Tools > Internet Options > Advanced > Printing > check Print background colors and images

J.2. Firefox

Windows:
File > Page Setup > Tab "Format&Option" > Option "Print Background (colors & images)"

Mac:
File > Print > check Print Background Colors

J.3. Safari

File > Print > check Print backgrounds
Anhang K. FAQ

How can I access timetables containing names of lecturers?
Authorized users (students, faculty) can login through the menu at the upper right corner of https://timetable.fhv.at. Authenticated users automatically receive URLs to timetables that contain names of lecturers. These data shall not be copied, transferred or otherwise be made available to third parties without the written consent of FHV.

How old are the data?
Timetables are generated with data from the database. However, after a request data are cached for one hour. The online-timetable shows the time when the data was read from the database last time at beneath the title of the timetable.

In the iCalendar file you can find the time when the data was read from the database last time at the line DTSTAMP of each event. The time is in UTC (winter time: CET = UTC + 1; summer time: CET = UTC + 2)

What is iCalendar and .ics respectively?
iCalendar is a file format for exchanging calendaring and scheduling information where the file has the extension .ics, specified in RFC 5545 http://tools.ietf.org/html/rfc5545.html.

What is the difference between importing and subscribing to an iCalendar file?
To import an iCalendar file into a calendaring software it needs to be downloaded first. Therefore, the file is a snapshot of the timetable at the time of downloading, or when it was last updated by the publisher. Changes to the timetable after the download go unnoticed. The idea of subscriptions is providing the URL to the iCalendar file to a calendaring software, that updates the data at a configurable frequency.

Why do I get a message that the iCalendar file is corrupt?
The message is either caused by a corrupt data file or by a software not compliant to the RFC 5545 specification. Even though we tested our files for compliancy, some issues may have gone unnoticed. Please validate the file with one of the following online validators:
http://severinghaus.org/projects/icv/
http://arnout.engelen.eu/icalendar-validator
http://icalvalid.cloudapp.net/Default.aspx

If you encounter warnings or error messages not concerning either CRLF or MIME, please send the file and/or the URL to helpdesk@fhv.at.